<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="profile" href="https://gmpg.org/xfn/11"><style type="text/css" media="all">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</style><title>PSU community mourns death of star athlete Deante Strickland - Vanguard</title><link rel="canonical" href="https://psuvanguard.com/psu-community-mourns-death-of-star-athlete-deante-strickland/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="PSU community mourns death of star athlete Deante Strickland - Vanguard" /><meta property="og:description" content="Portland State standout athlete Deante Strickland died in the afternoon of Aug. 2. Portland police said he was shot and killed at around 2 p.m. in Northeast Portland. He was..." /><meta property="og:url" content="https://psuvanguard.com/psu-community-mourns-death-of-star-athlete-deante-strickland/" /><meta property="og:site_name" content="Vanguard" /><meta property="article:tag" content="athlete" /><meta property="article:tag" content="Deante Strickland" /><meta property="article:tag" content="portland state" /><meta property="article:section" content="News" /><meta property="article:published_time" content="2019-08-06T23:55:08+00:00" /><meta property="article:modified_time" content="2019-08-06T23:55:28+00:00" /><meta property="og:updated_time" content="2019-08-06T23:55:28+00:00" /><meta property="og:image" content="https://psuvanguard.com/wp-content/uploads/2019/08/Deante-Strickland-Black-and-White.png" /><meta property="og:image:secure_url" content="https://psuvanguard.com/wp-content/uploads/2019/08/Deante-Strickland-Black-and-White.png" /><meta property="og:image:width" content="1920" /><meta property="og:image:height" content="1080" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Portland State standout athlete Deante Strickland died in the afternoon of Aug. 2. Portland police said he was shot and killed at around 2 p.m. in Northeast Portland. He was..." /><meta name="twitter:title" content="PSU community mourns death of star athlete Deante Strickland - Vanguard" /><meta name="twitter:image" content="https://psuvanguard.com/wp-content/uploads/2019/08/Deante-Strickland-Black-and-White.png" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://psuvanguard.com/#website","url":"https://psuvanguard.com/","name":"Vanguard","potentialAction":{"@type":"SearchAction","target":"https://psuvanguard.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://psuvanguard.com/psu-community-mourns-death-of-star-athlete-deante-strickland/#primaryimage","url":"https://psuvanguard.com/wp-content/uploads/2019/08/Deante-Strickland-Black-and-White.png","width":1920,"height":1080},{"@type":"WebPage","@id":"https://psuvanguard.com/psu-community-mourns-death-of-star-athlete-deante-strickland/#webpage","url":"https://psuvanguard.com/psu-community-mourns-death-of-star-athlete-deante-strickland/","inLanguage":"en-US","name":"PSU community mourns death of star athlete Deante Strickland - Vanguard","isPartOf":{"@id":"https://psuvanguard.com/#website"},"primaryImageOfPage":{"@id":"https://psuvanguard.com/psu-community-mourns-death-of-star-athlete-deante-strickland/#primaryimage"},"datePublished":"2019-08-06T23:55:08+00:00","dateModified":"2019-08-06T23:55:28+00:00","author":{"@id":"https://psuvanguard.com/#/schema/person/f857ab74c5c22f7e52018402fe7b3397"}},{"@type":["Person"],"@id":"https://psuvanguard.com/#/schema/person/f857ab74c5c22f7e52018402fe7b3397","name":"Dylan Jefferies","image":{"@type":"ImageObject","@id":"https://psuvanguard.com/#authorlogo","url":"https://psuvanguard.com/wp-content/uploads/2016/12/Vanguard_small_logo-100x100.png","caption":"Dylan Jefferies"},"sameAs":[]}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Vanguard &raquo; Feed" href="https://psuvanguard.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Vanguard &raquo; Comments Feed" href="https://psuvanguard.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Vanguard &raquo; PSU community mourns death of star athlete Deante Strickland Comments Feed" href="https://psuvanguard.com/psu-community-mourns-death-of-star-athlete-deante-strickland/feed/" /> <script type="text/javascript" data-cfasync="false">var mi_version         = '7.7.1';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-73100138-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-73100138-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/psuvanguard.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=c89814ef50f23c3a6a967ebf30dbec5d"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link crossorigin="anonymous" rel='stylesheet' id='carrino-google-font-poppins-css' href='https://fonts.googleapis.com/css?family=Poppins:400,500,600,700,700i,800,800i' type='text/css' media='all' /> <!--[if lt IE 9]><link rel='stylesheet' id='vc_lte_ie9-css'  href='https://psuvanguard.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?ver=6.0.5' type='text/css' media='screen' /> <![endif]--> <script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://psuvanguard.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript'>var gadwpUAEventsData = {"options":{"event_tracking":"1","event_downloads":"zip|mp3*|mpe*g|pdf|docx*|pptx*|xlsx*|rar*","event_bouncerate":0,"aff_tracking":0,"event_affiliates":"\/out\/","hash_tracking":0,"root_domain":"psuvanguard.com","event_timeout":100,"event_precision":0,"event_formsubmit":0,"ga_pagescrolldepth_tracking":0,"ga_with_gtag":0}};</script> <script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/psuvanguard.com","hash_tracking":"false"};</script> <script type='text/javascript'>var EM = {"ajaxurl":"https:\/\/psuvanguard.com\/wp-admin\/admin-ajax.php","locationajaxurl":"https:\/\/psuvanguard.com\/wp-admin\/admin-ajax.php?action=locations_search","firstDay":"1","locale":"en","dateFormat":"dd\/mm\/yy","ui_css":"https:\/\/psuvanguard.com\/wp-content\/plugins\/events-manager\/includes\/css\/jquery-ui.min.css","show24hours":"0","is_ssl":"1","txt_search":"Search","txt_searching":"Searching...","txt_loading":"Loading..."};</script> <script type='text/javascript'>var wpgmza_google_api_status = {"message":"Enqueued","code":"ENQUEUED"};</script> <script type='text/javascript'>var _EPYT_ = {"ajaxurl":"https:\/\/psuvanguard.com\/wp-admin\/admin-ajax.php","security":"146f728970","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/psuvanguard.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","eppath":"https:\/\/psuvanguard.com\/wp-content\/plugins\/youtube-embed-plus\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"13.1.1","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","stopMobileBuffer":"1","vi_active":"","vi_js_posttypes":[]};</script> <link rel='https://api.w.org/' href='https://psuvanguard.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://psuvanguard.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://psuvanguard.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://psuvanguard.com/?p=130470' /><link rel="alternate" type="application/json+oembed" href="https://psuvanguard.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fpsuvanguard.com%2Fpsu-community-mourns-death-of-star-athlete-deante-strickland%2F" /><link rel="alternate" type="text/xml+oembed" href="https://psuvanguard.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fpsuvanguard.com%2Fpsu-community-mourns-death-of-star-athlete-deante-strickland%2F&#038;format=xml" /><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." /><link rel="amphtml" href="https://psuvanguard.com/psu-community-mourns-death-of-star-athlete-deante-strickland/amp/"><link rel="icon" href="https://psuvanguard.com/wp-content/uploads/2017/10/cropped-VG-Transparent-logo-black-32x32.png" sizes="32x32" /><link rel="icon" href="https://psuvanguard.com/wp-content/uploads/2017/10/cropped-VG-Transparent-logo-black-192x192.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://psuvanguard.com/wp-content/uploads/2017/10/cropped-VG-Transparent-logo-black-180x180.png" /><meta name="msapplication-TileImage" content="https://psuvanguard.com/wp-content/uploads/2017/10/cropped-VG-Transparent-logo-black-270x270.png" /> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-73100138-1', 'auto');
  ga('send', 'pageview');</script> <noscript><style>.wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><meta property="og:locale" content="en_US" /><meta property="og:site_name" content="Vanguard" /><meta property="og:title" content="PSU community mourns death of star athlete Deante Strickland - Vanguard" /><meta property="og:url" content="https://psuvanguard.com/psu-community-mourns-death-of-star-athlete-deante-strickland/" /><meta property="og:type" content="article" /><meta property="og:description" content="Portland State standout athlete Deante Strickland died in the afternoon of Aug. 2. Portland police said he was shot and killed at around 2 p.m. in Northeast Portland. He was 22 years old. &quot;We are deeply saddened by the loss of Deante,&quot; said PSU Athletics Director Valerie Cleary. &quot;He represented ever" /><meta property="og:image" content="https://psuvanguard.com/wp-content/uploads/2019/08/Deante-Strickland-Black-and-White.png" /><meta property="og:image:url" content="https://psuvanguard.com/wp-content/uploads/2019/08/Deante-Strickland-Black-and-White.png" /><meta property="og:image:secure_url" content="https://psuvanguard.com/wp-content/uploads/2019/08/Deante-Strickland-Black-and-White.png" /><meta property="article:published_time" content="2019-08-06T16:55:08-07:00" /><meta property="article:modified_time" content="2019-08-06T16:55:28-07:00" /><meta property="og:updated_time" content="2019-08-06T16:55:28-07:00" /><meta property="article:section" content="News" /><meta itemprop="name" content="PSU community mourns death of star athlete Deante Strickland - Vanguard" /><meta itemprop="headline" content="PSU community mourns death of star athlete Deante Strickland - Vanguard" /><meta itemprop="description" content="Portland State standout athlete Deante Strickland died in the afternoon of Aug. 2. Portland police said he was shot and killed at around 2 p.m. in Northeast Portland. He was 22 years old. &quot;We are deeply saddened by the loss of Deante,&quot; said PSU Athletics Director Valerie Cleary. &quot;He represented ever" /><meta itemprop="image" content="https://psuvanguard.com/wp-content/uploads/2019/08/Deante-Strickland-Black-and-White.png" /><meta itemprop="datePublished" content="2019-08-06" /><meta itemprop="dateModified" content="2019-08-06T16:55:28-07:00" /><meta itemprop="author" content="Dylan Jefferies" /><meta name="twitter:title" content="PSU community mourns death of star athlete Deante Strickland - Vanguard" /><meta name="twitter:url" content="https://psuvanguard.com/psu-community-mourns-death-of-star-athlete-deante-strickland/" /><meta name="twitter:description" content="Portland State standout athlete Deante Strickland died in the afternoon of Aug. 2. Portland police said he was shot and killed at around 2 p.m. in Northeast Portland. He was 22 years old. &quot;We are deeply saddened by the loss of Deante,&quot; said PSU Athletics Director Valerie Cleary. &quot;He represented ever" /><meta name="twitter:image" content="https://psuvanguard.com/wp-content/uploads/2019/08/Deante-Strickland-Black-and-White.png" /><meta name="twitter:card" content="summary_large_image" /></head><body data-rsssl=1 class="post-template-default single single-post postid-130470 single-format-standard custom-background wp-custom-logo has-related-posts wpb-js-composer js-comp-ver-6.0.5 vc_responsive"><div class="body-fade"></div><div class="site-wrapper"><header id="site-header" class="site-header default"><div class="container header-layout-wrapper"> <span class="toggle toggle-menu mobile-only"> <span><i class="icon-menu-1"></i></span><span class="screen-reader-text">Menu</span> </span><div class="logo-wrapper"><a href="https://psuvanguard.com/" class="custom-logo-link" rel="home"><img src="https://psuvanguard.com/wp-content/uploads/2019/05/cropped-psuvg-01.png" alt="Vanguard" class="custom-logo" /></a></div> <span class="toggle toggle-search mobile-only"><span><i class="icon-search"></i></span><span class="screen-reader-text">Search</span></span></div><nav class="menu-primary-navigation-container"><ul id="primary-nav" class="primary-nav"><li class="toggle toggle-menu alignleft"><span><i class="icon-menu-1"></i></span><span class="screen-reader-text">Menu</span></li><li id="menu-item-82455" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-82455"><a href="https://psuvanguard.com/category/news/">News</a></li><li id="menu-item-117492" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117492"><a href="https://psuvanguard.com/category/international/">International</a></li><li id="menu-item-82457" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82457"><a href="https://psuvanguard.com/category/arts/">Arts &#038; Culture</a></li><li id="menu-item-82456" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82456"><a href="https://psuvanguard.com/category/opinion/">Opinion</a></li><li id="menu-item-117493" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117493"><a href="https://psuvanguard.com/category/sports/">Sports</a></li><li id="menu-item-82459" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82459"><a href="https://psuvanguard.com/category/multimedia/">Multimedia</a></li><li id="menu-item-117494" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117494"><a href="https://psuvanguard.com/category/guides/">Guides</a></li><li class="toggle toggle-search alignright"><span><i class="icon-search"></i></span><span class="screen-reader-text">Search</span></li></ul></nav></header><div class="site-search"> <i class="icon-cancel toggle-search"></i><form role="search" method="get" class="search-form" action="https://psuvanguard.com/"> <label for="search-form-5d4be0190820f"> <span class="screen-reader-text">Search for:</span> </label> <input type="search" id="search-form-5d4be0190820f" class="search-field" placeholder="Search and press Enter" value="" name="s" /> <button type="submit" class="search-submit"><i class="icon-search"></i><span class="screen-reader-text">Search</span></button></form></div><aside class="mobile-navigation slide-menu sidebar" aria-label="Blog Sidebar"> <span class="close-menu"><i class="icon-cancel"></i></span><div class="logo-wrapper"><a href="https://psuvanguard.com/" class="custom-logo-link" rel="home"><img src="https://psuvanguard.com/wp-content/uploads/2019/05/cropped-psuvg-01.png" alt="Vanguard" class="custom-logo" /></a></div><nav class="primary-nav-sidebar-wrapper mobile-only"><ul id="primary-nav-sidebar" class="primary-nav-sidebar"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-82455"><a href="https://psuvanguard.com/category/news/">News</a><span class="expand"></span></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117492"><a href="https://psuvanguard.com/category/international/">International</a><span class="expand"></span></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82457"><a href="https://psuvanguard.com/category/arts/">Arts &#038; Culture</a><span class="expand"></span></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82456"><a href="https://psuvanguard.com/category/opinion/">Opinion</a><span class="expand"></span></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117493"><a href="https://psuvanguard.com/category/sports/">Sports</a><span class="expand"></span></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82459"><a href="https://psuvanguard.com/category/multimedia/">Multimedia</a><span class="expand"></span></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117494"><a href="https://psuvanguard.com/category/guides/">Guides</a><span class="expand"></span></li></ul></nav><section id="search-3" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://psuvanguard.com/"> <label for="search-form-5d4be019092d0"> <span class="screen-reader-text">Search for:</span> </label> <input type="search" id="search-form-5d4be019092d0" class="search-field" placeholder="Search and press Enter" value="" name="s" /> <button type="submit" class="search-submit"><i class="icon-search"></i><span class="screen-reader-text">Search</span></button></form></section><section id="nav_menu-3" class="widget widget_nav_menu"><div class="menu-slideout-menu-container"><ul id="menu-slideout-menu" class="menu"><li id="menu-item-117516" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-117516"><a href="https://psuvanguard.com/arts-culture/">Arts &#038; Culture</a><ul class="sub-menu"><li id="menu-item-117517" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117517"><a href="https://psuvanguard.com/category/arts/campus-event-calendar/">Campus Event Calendar</a></li><li id="menu-item-117518" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117518"><a href="https://psuvanguard.com/category/arts/garbage-day/">Garbage Day</a></li></ul></li><li id="menu-item-117519" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117519"><a href="https://psuvanguard.com/category/international/">International</a></li><li id="menu-item-117520" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117520"><a href="https://psuvanguard.com/category/international/this-week-around-the-world/">This Week Around the World</a></li><li id="menu-item-117521" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-117521"><a href="https://psuvanguard.com/category/news/">News</a><ul class="sub-menu"><li id="menu-item-117522" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117522"><a href="https://psuvanguard.com/tag/crime-blotter/">Crime Blotter</a></li><li id="menu-item-117523" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117523"><a href="https://psuvanguard.com/tag/hill-to-hall/">Hill to Hall</a></li></ul></li><li id="menu-item-117524" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-117524"><a href="https://psuvanguard.com/category/opinion/">Opinion</a><ul class="sub-menu"><li id="menu-item-117525" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117525"><a href="https://psuvanguard.com/category/opinion/letters-to-the-editor/">Letters to the Editor</a></li><li id="menu-item-117526" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117526"><a href="https://psuvanguard.com/category/opinion/vikingvoices/">Viking Voices</a></li></ul></li><li id="menu-item-117527" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117527"><a href="https://psuvanguard.com/category/sports/">Sports</a></li><li id="menu-item-117528" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-117528"><a href="https://psuvanguard.com/category/guides/">Guides</a><ul class="sub-menu"><li id="menu-item-117529" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117529"><a href="https://psuvanguard.com/category/guides/love-sex-guide-2019/">Love &#038; Sex Guide 2019</a></li><li id="menu-item-117530" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117530"><a href="https://psuvanguard.com/category/guides/holiday-guide-2018/">Holiday Guide 2018</a></li><li id="menu-item-117531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117531"><a href="https://psuvanguard.com/category/guides/orientation-guide-2018/">Orientation Guide 2018</a></li><li id="menu-item-117532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117532"><a href="https://psuvanguard.com/category/guides/fourth-of-july-guide-2018/">Fourth of July Guide 2018</a></li><li id="menu-item-117533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117533"><a href="https://psuvanguard.com/category/guides/grad-guide-2018/">Grad Guide 2018</a></li><li id="menu-item-117534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117534"><a href="https://psuvanguard.com/category/guides/get-outside-guide-2018/">Get Outside Guide 2018</a></li><li id="menu-item-117535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117535"><a href="https://psuvanguard.com/category/guides/love-sex-guide-2018/">Love &#038; Sex Guide 2018</a></li></ul></li></ul></div></section></aside><div class="wrap"><main id="main" class="site-main"><div id="primary" class="content-area flex-grid the-post landscape-aspect-ratio"><article id="post-130470" class="flex-box single-post default post-130470 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-athlete tag-deante-strickland tag-portland-state"><div class="post-thumbnail"> <img width="1250" height="703" src="https://psuvanguard.com/wp-content/uploads/2019/08/Deante-Strickland-Black-and-White-1250x703.png" class="attachment-carrino-single-uncropped-image size-carrino-single-uncropped-image wp-post-image" alt="" srcset="https://psuvanguard.com/wp-content/uploads/2019/08/Deante-Strickland-Black-and-White-1250x703.png 1250w, https://psuvanguard.com/wp-content/uploads/2019/08/Deante-Strickland-Black-and-White-100x56.png 100w, https://psuvanguard.com/wp-content/uploads/2019/08/Deante-Strickland-Black-and-White-768x432.png 768w" sizes="(max-width: 1250px) 100vw, 1250px" /><div class="ccfic"><span class="ccfic-text">Deante Strickland passed away Aug. 2. He attended Portland State for the past two years where he played basketball and football. Courtesy of PSU Athletics. </span></div></div><header class="entry-header"><div class="entry-meta before-title"><ul class="author-category-meta"><li class="category-prepend"> <span class="screen-reader-text">Posted</span> <i>in</i></li><li class="category-list"><ul class="post-categories"><li><a href="https://psuvanguard.com/category/news/" rel="category tag">News</a></li></ul></li></ul></div><h1 class="entry-title"><span>PSU community mourns death of star athlete Deante Strickland</span></h1><div class="entry-meta after-title"><ul><li class="entry-author-meta"> <span class="screen-reader-text">Posted</span><i>by</i> <a href="https://psuvanguard.com/author/dylanjeff/">Dylan Jefferies</a></li><li class="entry-date"> <time datetime="2019-08-06">August 6, 2019</time></li><li class="entry-comment-count"> <a href="#comments"> 0 Comments </a></li></ul></div></header><div class="single-content-wrapper"><div class="sticky-container"><div class="sticky-element"><div class="share bottom"><ul class="social-icons icon-background theme"><li class="share-text">share</li><li class="social-icon twitter"><a rel="nofollow" href="https://twitter.com/share?url=https://psuvanguard.com/psu-community-mourns-death-of-star-athlete-deante-strickland/&amp;text=PSU%20community%20mourns%20death%20of%20star%20athlete%20Deante%20Strickland&amp;via=@psuvanguard" target="_blank"><i class="icon-twitter"></i></a></li><li class="social-icon facebook"><a rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://psuvanguard.com/psu-community-mourns-death-of-star-athlete-deante-strickland/" target="_blank"><i class="icon-facebook"></i></a></li></ul></div></div></div><div class="entry-content"><p><span style="font-weight: 400;">Portland State standout athlete Deante Strickland died in the afternoon of Aug. 2. Portland police said he was shot and killed at around 2 p.m. in Northeast Portland. He was 22 years old.</span></p><p><span style="font-weight: 400;">&#8220;We are deeply saddened by the loss of Deante,&#8221; said PSU Athletics Director </span><a href="https://goviks.com/staff.aspx?staff=152"><span style="font-weight: 400;">Valerie Cleary</span></a><span style="font-weight: 400;">. &#8220;He represented everything it means to be a Viking in his hometown of Portland. He will forever be remembered for his character, determination and warm smile. Our prayers go out to his family and friends.&#8221;</span><span style="font-weight: 400;"> </span></p><p><span style="font-weight: 400;">Strickland—who had attended PSU for two years—was a star basketball player and was set to play football for the Vikings in the fall. He was a social science major. </span></p><p><span style="font-weight: 400;">In an email sent out to the PSU community, Interim President Stephen Percy stated, “</span><span style="font-weight: 400;">We at Portland State are shocked and saddened by the tragic loss Friday of student athlete Deante Strickland.” </span></p><p><span style="font-weight: 400;">“We offer our condolences to the family, friends and others touched by [his] death.”</span></p><p><span style="font-weight: 400;">Viking basketball coach Barret Peery said of Strickland, </span><span style="font-weight: 400;">&#8220;We are better for having had Deante in our lives. His smile, passion and energy for life was second to none. He lit up a room and made the people around him better in every way. He loved his family, his friends and everyone around him. He had great pride in being a kid from Portland and it showed in how he competed each day. We will never forget him and he will always be with us.”</span></p><p><span style="font-weight: 400;">“I love Deante and am a better man for having the opportunity to coach him. This entire community will miss him.&#8221;</span></p><p><span style="font-weight: 400;">According to a statement released by the PSU athletics department, the Center for Student Health and Counseling (SHAC) and the athletics department are working to provide assistance to PSU athletes and the larger PSU community through the grieving process. </span></p></div></div></article><footer class="hentry-footer"><div class="entry-meta post-tags"><ul><li><a href="https://psuvanguard.com/tag/athlete/" aria-label="athlete">athlete</a></li><li><a href="https://psuvanguard.com/tag/deante-strickland/" aria-label="Deante Strickland">Deante Strickland</a></li><li><a href="https://psuvanguard.com/tag/portland-state/" aria-label="portland state">portland state</a></li></ul></div><div class="share bottom"><ul class="social-icons icon-background theme"><li class="share-text">share</li><li class="social-icon twitter"><a rel="nofollow" href="https://twitter.com/share?url=https://psuvanguard.com/psu-community-mourns-death-of-star-athlete-deante-strickland/&amp;text=PSU%20community%20mourns%20death%20of%20star%20athlete%20Deante%20Strickland&amp;via=@psuvanguard" target="_blank"><i class="icon-twitter"></i></a></li><li class="social-icon facebook"><a rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://psuvanguard.com/psu-community-mourns-death-of-star-athlete-deante-strickland/" target="_blank"><i class="icon-facebook"></i></a></li></ul></div></footer><div class="content-area post-navigation flex-grid cols-1 landscape-aspect-ratio"><h2 class="screen-reader-text">Post navigation</h2><article class="flex-box previous-article has-post-thumbnail  cover"><div class="post-thumbnail"> <a href="https://psuvanguard.com/events-calendar-aug-6-12/"><img width="900" height="600" src="https://psuvanguard.com/wp-content/uploads/2019/08/second-hand-590789_1920-900x600.jpg" class="attachment-carrino-landscape-image size-carrino-landscape-image wp-post-image" alt="" srcset="https://psuvanguard.com/wp-content/uploads/2019/08/second-hand-590789_1920-900x600.jpg 900w, https://psuvanguard.com/wp-content/uploads/2019/08/second-hand-590789_1920-1250x834.jpg 1250w" sizes="(max-width: 900px) 100vw, 900px" /><div class="ccfic"><span class="ccfic-text">Deante Strickland passed away Aug. 2. He attended Portland State for the past two years where he played basketball and football. Courtesy of PSU Athletics. </span></div></a></div><header class="entry-header"><div class="entry-meta before-title"> <span>previous post</span></div><h3 class="entry-title"><a href="https://psuvanguard.com/events-calendar-aug-6-12/">Events Calendar Aug. 6–12</a></h3></header></article></div><div class="content-area flex-grid threeforty-related-posts cols-3" data-posts="3"><article class="flex-box has-post-thumbnail odd post-1 has-category-meta default"><div class="post-thumbnail"> <a href="https://psuvanguard.com/where-oh-where-will-my-money-go/"> <img width="452" height="600" src="https://psuvanguard.com/wp-content/uploads/2018/01/SFC-Budget-recommendations-FY19.jpg" class="attachment-carrino-square-image size-carrino-square-image wp-post-image" alt="" srcset="https://psuvanguard.com/wp-content/uploads/2018/01/SFC-Budget-recommendations-FY19.jpg 598w, https://psuvanguard.com/wp-content/uploads/2018/01/SFC-Budget-recommendations-FY19-75x100.jpg 75w, https://psuvanguard.com/wp-content/uploads/2018/01/SFC-Budget-recommendations-FY19-317x420.jpg 317w" sizes="(max-width: 452px) 100vw, 452px" /> </a></div><div class="entry-header"><div class="entry-meta before-title"><ul class="author-category-meta"><li class="category-prepend"> <span class="screen-reader-text">Posted</span> <i>in</i></li><li class="category-list"><ul class="post-categories"><li><a href="https://psuvanguard.com/category/featured/">Featured</a></li><li><a href="https://psuvanguard.com/category/news/">News</a></li></ul></li></ul></div><h3 class="entry-title"><a href="https://psuvanguard.com/where-oh-where-will-my-money-go/" rel="bookmark">Where, oh where, will my money go?</a></h3><div class="entry-meta after-title"><ul><li class="entry-author-meta"> <span class="screen-reader-text">Posted</span><i>by</i> <a href="https://psuvanguard.com/author/colleen-leary/">Colleen Leary</a></li><li class="entry-date"> <time datetime="2018-01-17">January 17, 2018</time></li><li class="entry-comment-count"> 0 <span>Comments</span></li></ul></div></div></article><article class="flex-box has-post-thumbnail even post-2 has-category-meta default"><div class="post-thumbnail"> <a href="https://psuvanguard.com/crime-blotter-march-4-10/"> <img width="500" height="334" src="https://psuvanguard.com/wp-content/uploads/2017/01/crimeblotter-2-e1559259214792.jpg" class="attachment-carrino-square-image size-carrino-square-image wp-post-image" alt="" /> </a></div><div class="entry-header"><div class="entry-meta before-title"><ul class="author-category-meta"><li class="category-prepend"> <span class="screen-reader-text">Posted</span> <i>in</i></li><li class="category-list"><ul class="post-categories"><li><a href="https://psuvanguard.com/category/news/">News</a></li></ul></li></ul></div><h3 class="entry-title"><a href="https://psuvanguard.com/crime-blotter-march-4-10/" rel="bookmark">Crime Blotter March 4–10</a></h3><div class="entry-meta after-title"><ul><li class="entry-author-meta"> <span class="screen-reader-text">Posted</span><i>by</i> <a href="https://psuvanguard.com/author/chloedysart/">Chloe Dysart</a></li><li class="entry-date"> <time datetime="2019-03-12">March 12, 2019</time></li><li class="entry-comment-count"> 1 <span>Comment</span></li></ul></div></div></article><article class="flex-box has-post-thumbnail odd post-3 has-category-meta default"><div class="post-thumbnail"> <a href="https://psuvanguard.com/sharing-indian-culture-with-psu/"> <img width="600" height="400" src="https://psuvanguard.com/wp-content/uploads/2019/05/sanskriti2.jpg" class="attachment-carrino-square-image size-carrino-square-image wp-post-image" alt="" srcset="https://psuvanguard.com/wp-content/uploads/2019/05/sanskriti2.jpg 1732w, https://psuvanguard.com/wp-content/uploads/2019/05/sanskriti2-100x67.jpg 100w, https://psuvanguard.com/wp-content/uploads/2019/05/sanskriti2-768x512.jpg 768w, https://psuvanguard.com/wp-content/uploads/2019/05/sanskriti2-696x464.jpg 696w, https://psuvanguard.com/wp-content/uploads/2019/05/sanskriti2-1068x712.jpg 1068w, https://psuvanguard.com/wp-content/uploads/2019/05/sanskriti2-630x420.jpg 630w, https://psuvanguard.com/wp-content/uploads/2019/05/sanskriti2-1261x840.jpg 1261w" sizes="(max-width: 600px) 100vw, 600px" /> </a></div><div class="entry-header"><div class="entry-meta before-title"><ul class="author-category-meta"><li class="category-prepend"> <span class="screen-reader-text">Posted</span> <i>in</i></li><li class="category-list"><ul class="post-categories"><li><a href="https://psuvanguard.com/category/international/">International</a></li></ul></li></ul></div><h3 class="entry-title"><a href="https://psuvanguard.com/sharing-indian-culture-with-psu/" rel="bookmark">Sharing Indian culture with PSU</a></h3><div class="entry-meta after-title"><ul><li class="entry-author-meta"> <span class="screen-reader-text">Posted</span><i>by</i> <a href="https://psuvanguard.com/author/madison-cecil/">Madison Cecil</a></li><li class="entry-date"> <time datetime="2019-05-13">May 13, 2019</time></li><li class="entry-comment-count"> 0 <span>Comments</span></li></ul></div></div></article></div><div class="section-header"><h2 class="page-title toggle-comments"><span> Leave a Comment</span></h2></div><div id="comments" class="comments-area"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/psu-community-mourns-death-of-star-athlete-deante-strickland/?utm_source=rss&amp;utm_medium=rss&amp;utm_campaign=psu-community-mourns-death-of-star-athlete-deante-strickland#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://psuvanguard.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='130470' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="935b16c7b3" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="219" /></p></form></div></div></div></main></div><footer id="colophon" class="site-footer"><div class="container"><div class="footer-widget-area footer-columns flex-grid cols-3"><div class="flex-box footer-column-1"><section id="custom_html-4" class="widget_text widget widget_custom_html"><h3 class="widget-title">Follow us on Facebook</h3><div class="textwidget custom-html-widget"><div id="fb-root"></div> <script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = 'https://connect.facebook.net/en_US/all.js#xfbml=1&version=v2.12&appId=108684009781200&autoLogAppEvents=1';
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script></div></section><section id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="fb-page" data-href="http://www.facebook.com/portlandstatevanguard" data-tabs="timeline" data-small-header="true" data-ada[t-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/portlandstatevanguard/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/portlandstatevanguard/">PSU Vanguard</a></blockquote></div></div></section></div><div class="flex-box footer-column-2"><section id="media_image-5" class="widget widget_media_image"><h3 class="widget-title">We&#8217;re Hiring!</h3><a href="https://psuvanguard.com/jobs/"><img width="332" height="624" src="https://psuvanguard.com/wp-content/uploads/2019/06/unnamed-1.png" class="image wp-image-117597  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://psuvanguard.com/wp-content/uploads/2019/06/unnamed-1.png 332w, https://psuvanguard.com/wp-content/uploads/2019/06/unnamed-1-53x100.png 53w" sizes="(max-width: 332px) 100vw, 332px" /></a></section></div><div class="flex-box footer-column-3"><section id="null-instagram-feed-2" class="widget null-instagram-feed"><h3 class="widget-title">Instagram</h3><ul class="instagram-pics instagram-size-thumbnail"><li class=""><a href="//instagram.com/p/B0ZCA1rhqOv/" target="_self" class=""><img src="//scontent-ort2-1.cdninstagram.com/vp/0d524cb441d2d9ac5eb5341543a0bb0c/5DDE2D9F/t51.2885-15/e15/s150x150/64378216_461566098012287_3495952599714048867_n.jpg?_nc_ht=scontent-ort2-1.cdninstagram.com" alt="When comedian and actor Volodymyr Zelensky won 70% of the overall vote in the Ukrainian presidential elections last year, he took on the responsibility of the country’s struggling economy and the separatist-forces supported by Russia in the east. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
His only political experience comes from playing the president on a Ukrainian television show called Servant of the People.
⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
Read more about his first two months as president. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
LINK IN BIO" title="When comedian and actor Volodymyr Zelensky won 70% of the overall vote in the Ukrainian presidential elections last year, he took on the responsibility of the country’s struggling economy and the separatist-forces supported by Russia in the east. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
His only political experience comes from playing the president on a Ukrainian television show called Servant of the People.
⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
Read more about his first two months as president. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
LINK IN BIO" class="" /></a></li><li class=""><a href="//instagram.com/p/B0O2qqbh-Te/" target="_self" class=""><img src="//scontent-ort2-1.cdninstagram.com/vp/3f7d0802b629eafe5a3d127928c4ac49/5DD15BF5/t51.2885-15/e35/s150x150/66372239_927236760961186_8566879116399820497_n.jpg?_nc_ht=scontent-ort2-1.cdninstagram.com" alt="The decision to not vaccinate your child—for either person qualms or medical doubts—assigns you the label of an “anti-vaxxer.” ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
A dreadful combination of educational, economic and racial privilege has produced a belief that one knows better than the scientific and medical communities at large. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
Getting vaccinated is a social responsibility, not a personal one. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
Read more now. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
LINK IN BIO" title="The decision to not vaccinate your child—for either person qualms or medical doubts—assigns you the label of an “anti-vaxxer.” ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
A dreadful combination of educational, economic and racial privilege has produced a belief that one knows better than the scientific and medical communities at large. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
Getting vaccinated is a social responsibility, not a personal one. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
Read more now. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
LINK IN BIO" class="" /></a></li><li class=""><a href="//instagram.com/p/B0KOT3YhpEZ/" target="_self" class=""><img src="//scontent-ort2-1.cdninstagram.com/vp/0f7911bb919f72d316c3debc733a4b02/5DE83FBD/t51.2885-15/e15/c216.0.648.648a/s150x150/66422795_508594329910489_4421203828074525538_n.jpg?_nc_ht=scontent-ort2-1.cdninstagram.com" alt="It&#039;s Your Fault!
⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀
Want more comics? Make sure to check out our newest issue for the latest news and comics. ⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀
Read about what protestors are demanding from the Lights of Liberty protest, cocaine production in Colombia,  desensitization on social media and more!
⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀
(Comic by John Rojas)
⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀
LINK IN BIO" title="It&#039;s Your Fault!
⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀
Want more comics? Make sure to check out our newest issue for the latest news and comics. ⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀
Read about what protestors are demanding from the Lights of Liberty protest, cocaine production in Colombia,  desensitization on social media and more!
⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀
(Comic by John Rojas)
⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀
LINK IN BIO" class="" /></a></li><li class=""><a href="//instagram.com/p/Bz1XqNgBj2s/" target="_self" class=""><img src="//scontent-ort2-1.cdninstagram.com/vp/daf3d9cd20305a59390027e462ede806/5D4E898C/t51.2885-15/e35/c157.0.406.406a/s150x150/66297530_916388018700702_4509340651524563248_n.jpg?_nc_ht=scontent-ort2-1.cdninstagram.com" alt="The Waterfront Blues Festival held their 32nd annual music event from July 4 to 7 at the Tom McCall Waterfront Park! ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
Over the course of four days, the festival celebrated blues by featuring various musician performances, food, workshops and more.  The Waterfront Blues Festival is the largest blues events west of the Mississippi River." title="The Waterfront Blues Festival held their 32nd annual music event from July 4 to 7 at the Tom McCall Waterfront Park! ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
Over the course of four days, the festival celebrated blues by featuring various musician performances, food, workshops and more.  The Waterfront Blues Festival is the largest blues events west of the Mississippi River." class="" /></a></li><li class=""><a href="//instagram.com/p/BzmJTMLBvQG/" target="_self" class=""><img src="//scontent-ort2-1.cdninstagram.com/vp/2caa753c3e7721f961560a975c96b8e2/5DDCCD73/t51.2885-15/e35/s150x150/65159556_417259302332147_4187002666210557070_n.jpg?_nc_ht=scontent-ort2-1.cdninstagram.com" alt="“Satanic feminist; Hex the patriarchy” ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀
Satan and doo-wop don’t seem like a fitting pair, but Alexandra and Zachary James are the Los Angeles duo who somehow figured out a way to make it work. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀
Known as Twin Temple, they&#039;re also feminists and they don’t try to hide it. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀
Discover how they brought Satanic feminism to Portland! ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀
LINK IN BIO ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
(Photos by Cervanté Pope)" title="“Satanic feminist; Hex the patriarchy” ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀
Satan and doo-wop don’t seem like a fitting pair, but Alexandra and Zachary James are the Los Angeles duo who somehow figured out a way to make it work. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀
Known as Twin Temple, they&#039;re also feminists and they don’t try to hide it. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀
Discover how they brought Satanic feminism to Portland! ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀
LINK IN BIO ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
(Photos by Cervanté Pope)" class="" /></a></li><li class=""><a href="//instagram.com/p/BzcXTzOhf7S/" target="_self" class=""><img src="//scontent-ort2-1.cdninstagram.com/vp/ccb054b720e1a105e13e25e61c545405/5DDF0D1A/t51.2885-15/e35/s150x150/64674161_149493969527513_6624478517694723180_n.jpg?_nc_ht=scontent-ort2-1.cdninstagram.com" alt="⁣Two speakers went before the Board of Trustees to discuss the creation of a Dream success center at PSU.⠀
⁣ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ Deferred Action for Childhood Arrivals (DACA) temporarily grants young immigrants—brought to the U.S. illegally as children—protection from deportation. DACA recipients are often referred to as “Dreamers.”⠀
⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ The monarch butterfly often associated with Dreamers represents the natural act of migration and the right of all living individuals to move freely. ⠀
⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀ The Dream Success Center would allow undocumented students to find all the resources and support they may need.
⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
LINK IN BIO" title="⁣Two speakers went before the Board of Trustees to discuss the creation of a Dream success center at PSU.⠀
⁣ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ Deferred Action for Childhood Arrivals (DACA) temporarily grants young immigrants—brought to the U.S. illegally as children—protection from deportation. DACA recipients are often referred to as “Dreamers.”⠀
⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ The monarch butterfly often associated with Dreamers represents the natural act of migration and the right of all living individuals to move freely. ⠀
⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀ The Dream Success Center would allow undocumented students to find all the resources and support they may need.
⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
LINK IN BIO" class="" /></a></li><li class=""><a href="//instagram.com/p/BzBwxl8BXeS/" target="_self" class=""><img src="//scontent-ort2-1.cdninstagram.com/vp/1c57785a4293612c32580e668eed78b0/5DD56D00/t51.2885-15/e15/s150x150/62579001_407976996475244_384253317121406566_n.jpg?_nc_ht=scontent-ort2-1.cdninstagram.com" alt="⁣After months of calling for a civilian-led government, Sudan&#039;s protest leaders called for nighttime demonstrations in Khartoum on June 17.⠀
⠀
Thousands of demonstrators camped outside the military headquarters from mid-April until June 3 before the military forcibly removed them from the area.⠀
⠀
The military raided the protesters’ campsites and fired guns into the area, killing over 100 people.  Read more about the escalation of Sudanese protests now. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
LINK IN BIO" title="⁣After months of calling for a civilian-led government, Sudan&#039;s protest leaders called for nighttime demonstrations in Khartoum on June 17.⠀
⠀
Thousands of demonstrators camped outside the military headquarters from mid-April until June 3 before the military forcibly removed them from the area.⠀
⠀
The military raided the protesters’ campsites and fired guns into the area, killing over 100 people.  Read more about the escalation of Sudanese protests now. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
LINK IN BIO" class="" /></a></li><li class=""><a href="//instagram.com/p/By3vnZ9hrx9/" target="_self" class=""><img src="//scontent-ort2-1.cdninstagram.com/vp/57dcf477c9fa667efb547beab6764473/5DD45035/t51.2885-15/e35/s150x150/61601268_2320674404821121_3004373266672608674_n.jpg?_nc_ht=scontent-ort2-1.cdninstagram.com" alt="Looking for your next Instagram post? We’ve got you covered! ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
Thanks to Portland’s eccentric art community, incredible murals have popped up all over the city. The colors, unique depictions and artistry, make these spots some of the most Instagrammable! ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
From iconic bananas to using more than 1,000 succulents, discover our guide for the top 10 most Instagrammable murals in Portland! ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
LINK IN THE BIO" title="Looking for your next Instagram post? We’ve got you covered! ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
Thanks to Portland’s eccentric art community, incredible murals have popped up all over the city. The colors, unique depictions and artistry, make these spots some of the most Instagrammable! ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
From iconic bananas to using more than 1,000 succulents, discover our guide for the top 10 most Instagrammable murals in Portland! ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
LINK IN THE BIO" class="" /></a></li><li class=""><a href="//instagram.com/p/Byl5UzKBoab/" target="_self" class=""><img src="//scontent-ort2-1.cdninstagram.com/vp/4627bbb0ae2b1798e1bcd897690ac53d/5D4E8DF5/t51.2885-15/e35/s150x150/64647242_686896605072549_416894887728977761_n.jpg?_nc_ht=scontent-ort2-1.cdninstagram.com" alt="Summer is right around the corner, and so is the MAX! ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
Getting outside and exploring nature is a great summertime activity that can be good for your mental and physical health. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
The Portland metro area has nearly 150 parks, and a handful of those are accessible by public transit! ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
Click the link in the bio to discover them 🌲🌲" title="Summer is right around the corner, and so is the MAX! ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
Getting outside and exploring nature is a great summertime activity that can be good for your mental and physical health. ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
The Portland metro area has nearly 150 parks, and a handful of those are accessible by public transit! ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀ ⠀⠀⠀⠀⠀⠀⠀⠀⠀
Click the link in the bio to discover them 🌲🌲" class="" /></a></li></ul><p class="clear"><a href="//instagram.com/psuvanguard/" rel="me" target="_self" class="">Follow Us!</a></p></section></div></div><ul class="footer-info"><li class="footer-copyright"> Portland State&#039;s student-run newspaper</li><li class="footer-links"><ul id="footer-nav" class="footer-nav"><li id="menu-item-117588" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-117588"><a href="https://psuvanguard.com/author-list/">Authors</a></li><li id="menu-item-117590" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-117590"><a href="https://psuvanguard.com/jobs/">Jobs</a></li><li id="menu-item-117589" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-117589"><a href="https://psuvanguard.com/contact-2/">Contact</a></li></ul></li></ul></div></footer> <a href="" class="goto-top backtotop"><i class="icon-up-open"></i></a></div><script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/psuvanguard.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript'>var pollsL10n = {"ajax_url":"https:\/\/psuvanguard.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};</script> <script type="text/javascript" defer src="https://psuvanguard.com/wp-content/cache/autoptimize/js/autoptimize_fc75b2d8a56ad1bdab7f563181e1ddc9.js"></script></body></html>